実験 2 と同様に、次のような、3つのネットワークを2台のルータで接続したネットワークを構築する実験を行います。
但し、これを実現するのに、ルータ一台の他、スイッチ一台、パソコン一台だ けを使用します。 さらに、ルータも VLAN を使用し、すべてのルーティングを VLAN に対して行うようにします。
まず、ルータ、スイッチ、PC を接続します。 ルータの FastEthernet0/1 をスイッチの FastEthernet0/7 につなぎます。 PC をスイッチの FastEthernet0/8 につなぎます。
また、ルータやスイッチを接続するためのシリアルケーブルを PC に接続しま す。 PC では Tera Term などの端末ソフトを起動します。
設定はポート 7 は dot1q 指定の trunc に指定し、 VLAN15 と VLAN16 を通します。 そして、ポート 8 は dot1q 指定の trunc に指定し、VLAN14 と VLAN15 を通 します。 内部のルータは VLAN14 と VLAN16 に接続し、それぞれ IP アドレスとして、 172.20.13.1/24 と 172.20.15.2/24 を設定します。
configure terminal
vlan 14
exit
vlan 15
exit
vlan 16
exit
ip routing
interface fastethernet0/7
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 15,16
exit
interface fastethernet0/8
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 14,15
exit
interface vlan 14
ip address 172.20.13.1 255.255.255.0
no shutdown
exit
interface vlan 16
ip address 172.20.15.2 255.255.255.0
no shutdown
end
スイッチの設定の確認は show vlan、show interfaces FastEthernet0/8 switchport などで確認します。
catalyst3560#show vlan VLAN Name Status Ports ---- -------------------------------- --------- ------------------------------- 1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4 Fa0/5, Gi0/1 3 VLAN0003 active 4 VLAN0014 active 5 VLAN0015 active Fa0/7 6 VLAN0016 active Fa0/7 1002 fddi-default act/unsup 1003 token-ring-default act/unsup 1004 fddinet-default act/unsup 1005 trnet-default act/unsup VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2 ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------ 1 enet 100001 1500 - - - - - 0 0 3 enet 100003 1500 - - - - - 0 0 14 enet 100004 1500 - - - - - 0 0 15 enet 100005 1500 - - - - - 0 0 1002 fddi 101002 1500 - - - - - 0 0 1003 tr 101003 1500 - - - - - 0 0 1004 fdnet 101004 1500 - - - ieee - 0 0 1005 trnet 101005 1500 - - - ibm - 0 0 Remote SPAN VLANs ------------------------------------------------------------------------------ Primary Secondary Type Ports ------- --------- ----------------- ------------------------------------------
catalyst3560#show interfaces vlan 14 Vlan4 is up, line protocol is up Hardware is EtherSVI, address is 0025.83c7.fc42 (bia 0025.83c7.fc42) Internet address is 172.20.13.1/24 MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec, reliability 255/255, txload 1/255, rxload 1/255 Encapsulation ARPA, loopback not set ARP type: ARPA, ARP Timeout 04:00:00 Last input 00:00:01, output 00:04:16, output hang never Last clearing of "show interface" counters never Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 Queueing strategy: fifo Output queue: 0/40 (size/max) 5 minute input rate 0 bits/sec, 0 packets/sec 5 minute output rate 0 bits/sec, 0 packets/sec 69 packets input, 6651 bytes, 0 no buffer Received 0 broadcasts (0 IP multicasts) 0 runts, 0 giants, 0 throttles 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored 2 packets output, 128 bytes, 0 underruns 0 output errors, 0 interface resets 0 output buffer failures, 0 output buffers swapped out
catalyst3560#show interfaces FastEthernet 0/8 switchport Name: Fa0/8 Switchport: Enabled Administrative Mode: trunk Operational Mode: trunk Administrative Trunking Encapsulation: dot1q Operational Trunking Encapsulation: dot1q Negotiation of Trunking: On Access Mode VLAN: 1 (default) Trunking Native Mode VLAN: 3 (VLAN0003) Administrative Native VLAN tagging: enabled Voice VLAN: none Administrative private-vlan host-association: none Administrative private-vlan mapping: none Administrative private-vlan trunk native VLAN: none Administrative private-vlan trunk Native VLAN tagging: enabled Administrative private-vlan trunk encapsulation: dot1q Administrative private-vlan trunk normal VLANs: none Administrative private-vlan trunk private VLANs: none Operational private-vlan: none Trunking VLANs Enabled: 14,15 Pruning VLANs Enabled: 2-1001 Capture Mode Disabled Capture VLANs Allowed: ALL Protected: false Unknown unicast blocked: disabled Unknown multicast blocked: disabled Appliance trust: none
catalyst3560#show ip route Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route Gateway of last resort is not set 172.20.0.0/24 is subnetted, 2 subnets C 172.20.13.0 is directly connected, Vlan14 C 172.20.15.0 is directly connected, FastEthernet0/6
実験 2 に対して、 Ethernet のポートではなく VLAN のルーティングを行います。 そのため、仮想ポートを設定して、ルーティングします。
configure terminal
interface FastEthernet0/1
no ip address
no shutdown
exit
interface FastEthernet0/1.5
encapsulation dot1Q 5
ip address 172.20.12.1 255.255.255.0
no shutdown
exit
interface FastEthernet0/1.6
encapsulation dot1Q 6
ip address 172.20.15.1 255.255.255.0
no shutdown
end
上記のように FastEthernet のポートに対して、サブインターフェイス番号を割り当て、そこで VLAN の設定を行います。
この時、サブインターフェイス番号と VLAN 番号は異なっていても構いません。
VLAN の設定はあくまでも
設定を確認するには、 show ip route を打つことで、自動的にルー ティングテーブルに接続したポートが自動的に追加されていることが確認でき ます。
yourname#show ip route Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route Gateway of last resort is not set 172.20.0.0/24 is subnetted, 2 subnets C 172.20.12.0 is directly connected, FastEthernet0/1.5 C 172.20.15.0 is directly connected, FastEthernet0/1.6
では次にルーティングを設定しましょう。 どちらも RIP を使用します。
configure terminal
router rip
network 172.20.0.0
end
configure terminal
router rip
network 172.20.0.0
end
このときのルーティングテーブルは次の様になっています。
172.20.0.0/24 is subnetted, 3 subnets C 172.20.12.0 is directly connected, FastEthernet0/1 R 172.20.13.0 [120/1] via 172.20.15.2, 00:00:19, FastEthernet0/0 C 172.20.15.0 is directly connected, FastEthernet0/0
172.20.0.0/24 is subnetted, 3 subnets R 172.20.12.0 [120/1] via 172.20.15.1, 00:00:05, FastEthernet0/6 C 172.20.13.0 is directly connected, Vlan14 C 172.20.15.0 is directly connected, FastEthernet0/6
また、 Wire Shark で取得できる RIP のパケットは次の様になっています。
ルータが2台以上あると、相互に独立に接続しているネットワークの情報を知 らなければなりません。 手動で行うのはスタティックルーティングで、これは各情報をじかに入力する ものです。 一方ダイナミックルーティングとして RIP があります。
また、 ping に関して、行きの経路が無い場合は ICMP unreachable を受ける ためエラーを検知できますが、帰りの経路が無い場合はエラーを受けることが できずタイムアウトします。